DMVPN中心站点动态域名解析

一般情况下CISCO的DMVPN中心站点使用固定IP地址,但是有些情况下无法获取固定的IP地址,在这种情况下Spoke端将无法和Hub端进行通信。

其实可以在Hub端使用动态域名,然后Spoke端使用动态域名解析进行通讯。Hub无需做其他配置,只需要配置DDNS即可。

Spoke端原有配置:

interface Tunnel0
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp network-id 10
 ip nhrp map 192.168.1.254 202.100.1.1
 ip nhrp map multicast 202.100.1.1
 ip nhrp nhs 192.168.1.254
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel protection ipsec profile dmvpn

Spoke端更新后配置:

interface Tunnel0
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp network-id 10
 ip nhrp nhs dynamic nbma nj-home.iteachs.com multicast
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel protection ipsec profile dmvpn

发表评论

电子邮件地址不会被公开。 必填项已用*标注

答案 : *
24 − 2 =