NXOS9000v VxLAN配置实验

2017-4-1 hale 技术

前段时间研究了VxLAN的相关知识,但是都是基于CSR1000v的实验,这次我的实验使用NXOS9K来做了。

拓扑:

2017-04-01

配置:

NXOS1:

hostname N9K-1

feature ospf

feature pim

no ip domain-lookup

ip pim rp-address 10.0.0.1 group-list 224.0.0.0/4

ip pim ssm range 232.0.0.0/8

ip pim anycast-rp 10.0.0.1 10.1.1.1

ip pim anycast-rp 10.0.0.1 10.1.1.2

!

interface Ethernet1/1

  description To-LEAF-3

  no switchport

  ip address 192.168.13.1/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface Ethernet1/2

  description To-LEAF-4

  no switchport

  ip address 192.168.14.1/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface loopback0

  description For-Manager

  ip address 10.1.1.1/32

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

!

interface loopback1

  description For-AnycastRP

  ip address 10.0.0.1/32

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

router ospf 1

  router-id 10.1.1.1


NXOS-2:

hostname N9K-2

feature ospf

feature pim

ip pim rp-address 10.0.0.1 group-list 224.0.0.0/4

ip pim ssm range 232.0.0.0/8

ip pim anycast-rp 10.0.0.1 10.1.1.1

ip pim anycast-rp 10.0.0.1 10.1.1.2

!

interface Ethernet1/1

  description To-LEAF-3

  no switchport

  ip address 192.168.23.2/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface Ethernet1/2

  description To-LEAF-4

  no switchport

  ip address 192.168.24.2/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface loopback0

  description For-Manager

  ip address 10.1.1.2/32

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

!

interface loopback1

  description For-AnycastRP

  ip address 10.0.0.1/32

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

router ospf 1

  router-id 10.1.1.2


NXOS-3:

hostname N9K-3

!

feature ospf

feature pim

feature vn-segment-vlan-based

feature nv overlay

vlan 1,100

ip pim rp-address 10.0.0.1 group-list 224.0.0.0/4

ip pim ssm range 232.0.0.0/8

vlan 100

  name VxLAN

  vn-segment 10000

!

interface nve1

  no shutdown

  source-interface loopback0

  member vni 10000 mcast-group 234.1.1.1

!

interface Ethernet1/1

  description To-SPINE-1

  no switchport

  ip address 192.168.13.3/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface Ethernet1/2

  description To-SPINE-2

  no switchport

  ip address 192.168.23.3/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface Ethernet1/7

  switchport access vlan 100

!

interface loopback0

  description For-Manager

  ip address 10.1.1.3/32

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

router ospf 1

  router-id 10.1.1.3


NXOS-4:

hostname N9K-4

!

feature ospf

feature pim

feature vn-segment-vlan-based

feature nv overlay

!

vlan 1,100

ip pim rp-address 10.0.0.1 group-list 224.0.0.0/4

ip pim ssm range 232.0.0.0/8

vlan 100

  name VxLAN

  vn-segment 10000

!

interface nve1

  no shutdown

  source-interface loopback0

  member vni 10000 mcast-group 234.1.1.1

!

interface Ethernet1/1

  description To-SPINE-1

  no switchport

  ip address 192.168.14.4/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface Ethernet1/2

  description To-SPINE-2

  no switchport

  ip address 192.168.24.4/24

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

  no shutdown

!

interface Ethernet1/7

  switchport access vlan 100

!

interface loopback0

  description For-Manager

  ip address 10.1.1.4/32

  ip ospf network point-to-point

  ip router ospf 1 area 0.0.0.0

  ip pim sparse-mode

router ospf 1

  router-id 10.1.1.4


R5:

hostname R5

!

interface FastEthernet0/0

 ip address 192.168.1.1 255.255.255.0

 no shutdown

!

R6:

hostname R6

!

interface FastEthernet0/0

 ip address 192.168.1.2 255.255.255.0

 no shutdown 

!

测试:

R5#ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 52/64/112 ms

R5#show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  192.168.1.1             -   ca05.01d8.0000  ARPA   FastEthernet0/0

Internet  192.168.1.2           177   ca06.033a.0000  ARPA   FastEthernet0/0

 

R6#ping 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 48/53/60 ms

R6#show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  192.168.1.1           177   ca05.01d8.0000  ARPA   FastEthernet0/0

Internet  192.168.1.2             -   ca06.033a.0000  ARPA   FastEthernet0/0

R6#

 

 

查看:

NXOS-1

N9K-1# show cdp neighbors

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater,

                  V - VoIP-Phone, D - Remotely-Managed-Device,

                  s - Supports-STP-Dispute

 

Device-ID          Local Intrfce  Hldtme Capability  Platform      Port ID

N9K-3(9XC74SQNCI4)

                    Eth1/1         167    R S s     N9K-NXOSV     Eth1/1

N9K-4(9MD9PSOKKFU)

                    Eth1/2         174    R S s     N9K-NXOSV     Eth1/1

 

Total entries displayed: 2

N9K-1# show ip ospf neighbors

 OSPF Process ID 1 VRF default

 Total number of neighbors: 2

 Neighbor ID     Pri State            Up Time  Address         Interface

 10.1.1.3          1 FULL/ -          3d22h    192.168.13.3    Eth1/1

 10.1.1.4          1 FULL/ -          3d22h    192.168.14.4    Eth1/2

N9K-1#

N9K-1# show ip route

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

 

10.0.0.1/32, ubest/mbest: 2/0, attached

    *via 10.0.0.1, Lo1, [0/0], 3d23h, local

    *via 10.0.0.1, Lo1, [0/0], 3d23h, direct

10.1.1.1/32, ubest/mbest: 2/0, attached

    *via 10.1.1.1, Lo0, [0/0], 3d23h, local

    *via 10.1.1.1, Lo0, [0/0], 3d23h, direct

10.1.1.2/32, ubest/mbest: 2/0

    *via 192.168.13.3, Eth1/1, [110/81], 3d22h, ospf-1, intra

    *via 192.168.14.4, Eth1/2, [110/81], 3d22h, ospf-1, intra

10.1.1.3/32, ubest/mbest: 1/0

    *via 192.168.13.3, Eth1/1, [110/41], 3d17h, ospf-1, intra

10.1.1.4/32, ubest/mbest: 1/0

    *via 192.168.14.4, Eth1/2, [110/41], 3d22h, ospf-1, intra

192.168.13.0/24, ubest/mbest: 1/0, attached

    *via 192.168.13.1, Eth1/1, [0/0], 3d22h, direct

192.168.13.1/32, ubest/mbest: 1/0, attached

    *via 192.168.13.1, Eth1/1, [0/0], 3d22h, local

192.168.14.0/24, ubest/mbest: 1/0, attached

    *via 192.168.14.1, Eth1/2, [0/0], 3d22h, direct

192.168.14.1/32, ubest/mbest: 1/0, attached

    *via 192.168.14.1, Eth1/2, [0/0], 3d22h, local

192.168.23.0/24, ubest/mbest: 1/0

    *via 192.168.13.3, Eth1/1, [110/80], 3d22h, ospf-1, intra

192.168.24.0/24, ubest/mbest: 1/0

    *via 192.168.14.4, Eth1/2, [110/80], 3d22h, ospf-1, intra

N9K-1#

N9K-1# show ip pim neighbor

PIM Neighbor Status for VRF "default"

Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD

                                                         Priority Capable State

192.168.13.3    Ethernet1/1          3d22h     00:01:41  1        yes     n/a

192.168.14.4    Ethernet1/2          3d22h     00:01:37  1        yes     n/a

N9K-1# show ip mroute

IP Multicast Routing Table for VRF "default"

 

(*, 232.0.0.0/8), uptime: 3d23h, pim ip

  Incoming interface: Null, RPF nbr: 0.0.0.0, uptime: 3d23h

  Outgoing interface list: (count: 0)

 

(*, 234.1.1.1/32), uptime: 1d05h, pim ip

  Incoming interface: loopback1, RPF nbr: 10.0.0.1, uptime: 1d05h

  Outgoing interface list: (count: 1)

    Ethernet1/1, uptime: 1d05h, pim

 

(10.1.1.3/32, 234.1.1.1/32), uptime: 1d05h, pim mrib ip

  Incoming interface: Ethernet1/1, RPF nbr: 192.168.13.3, uptime: 1d05h, interna

l

  Outgoing interface list: (count: 1)

    Ethernet1/1, uptime: 00:11:09, pim, (RPF)

 

(10.1.1.4/32, 234.1.1.1/32), uptime: 1d05h, pim mrib ip

  Incoming interface: Ethernet1/2, RPF nbr: 192.168.14.4, uptime: 1d05h, interna

l

  Outgoing interface list: (count: 1)

    Ethernet1/1, uptime: 00:11:09, pim

 

N9K-1#

 

NXOS-2

N9K-2# show cdp neighbors

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater,

                  V - VoIP-Phone, D - Remotely-Managed-Device,

                  s - Supports-STP-Dispute

 

Device-ID          Local Intrfce  Hldtme Capability  Platform      Port ID

N9K-3(9XC74SQNCI4)

                    Eth1/1         176    R S s     N9K-NXOSV     Eth1/2

N9K-4(9MD9PSOKKFU)

                    Eth1/2         124    R S s     N9K-NXOSV     Eth1/2

 

Total entries displayed: 2

N9K-2#

N9K-2# show ip os neighbors

 OSPF Process ID 1 VRF default

 Total number of neighbors: 2

 Neighbor ID     Pri State            Up Time  Address         Interface

 10.1.1.3          1 FULL/ -          3d22h    192.168.23.3    Eth1/1

 10.1.1.4          1 FULL/ -          3d22h    192.168.24.4    Eth1/2

N9K-2#

N9K-2# show ip route

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

 

10.0.0.1/32, ubest/mbest: 2/0, attached

    *via 10.0.0.1, Lo1, [0/0], 3d22h, local

    *via 10.0.0.1, Lo1, [0/0], 3d22h, direct

10.1.1.1/32, ubest/mbest: 2/0

    *via 192.168.23.3, Eth1/1, [110/81], 3d22h, ospf-1, intra

    *via 192.168.24.4, Eth1/2, [110/81], 3d22h, ospf-1, intra

10.1.1.2/32, ubest/mbest: 2/0, attached

    *via 10.1.1.2, Lo0, [0/0], 3d22h, local

    *via 10.1.1.2, Lo0, [0/0], 3d22h, direct

10.1.1.3/32, ubest/mbest: 1/0

    *via 192.168.23.3, Eth1/1, [110/41], 3d17h, ospf-1, intra

10.1.1.4/32, ubest/mbest: 1/0

    *via 192.168.24.4, Eth1/2, [110/41], 3d22h, ospf-1, intra

192.168.13.0/24, ubest/mbest: 1/0

    *via 192.168.23.3, Eth1/1, [110/80], 3d22h, ospf-1, intra

192.168.14.0/24, ubest/mbest: 1/0

    *via 192.168.24.4, Eth1/2, [110/80], 3d22h, ospf-1, intra

192.168.23.0/24, ubest/mbest: 1/0, attached

    *via 192.168.23.2, Eth1/1, [0/0], 3d22h, direct

192.168.23.2/32, ubest/mbest: 1/0, attached

    *via 192.168.23.2, Eth1/1, [0/0], 3d22h, local

192.168.24.0/24, ubest/mbest: 1/0, attached

    *via 192.168.24.2, Eth1/2, [0/0], 3d22h, direct

192.168.24.2/32, ubest/mbest: 1/0, attached

    *via 192.168.24.2, Eth1/2, [0/0], 3d22h, local

N9K-2#

N9K-2# show ip pim neighbor

PIM Neighbor Status for VRF "default"

Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD

                                                         Priority Capable State

192.168.23.3    Ethernet1/1          3d22h     00:01:40  1        yes     n/a

192.168.24.4    Ethernet1/2          3d22h     00:01:36  1        yes     n/a

N9K-2# show ip mroute

IP Multicast Routing Table for VRF "default"

 

(*, 232.0.0.0/8), uptime: 23:12:46, pim ip

  Incoming interface: Null, RPF nbr: 0.0.0.0, uptime: 23:12:46

  Outgoing interface list: (count: 0)

 

(*, 234.1.1.1/32), uptime: 23:12:46, pim ip

  Incoming interface: loopback1, RPF nbr: 10.0.0.1, uptime: 23:12:46

  Outgoing interface list: (count: 1)

    Ethernet1/2, uptime: 23:12:46, pim

 

(10.1.1.3/32, 234.1.1.1/32), uptime: 23:12:46, pim mrib ip

  Incoming interface: Ethernet1/1, RPF nbr: 192.168.23.3, uptime: 23:12:46, inte

rnal

  Outgoing interface list: (count: 1)

    Ethernet1/2, uptime: 23:12:46, pim

 

(10.1.1.4/32, 234.1.1.1/32), uptime: 23:12:46, pim mrib ip

  Incoming interface: Ethernet1/2, RPF nbr: 192.168.24.4, uptime: 23:12:46, inte

rnal

  Outgoing interface list: (count: 2)

    Ethernet1/2, uptime: 00:12:31, pim, (RPF)

    Ethernet1/1, uptime: 23:12:46, pim

 

N9K-2#

 

NXOS-3:

N9K-3# show cdp neighbors

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater,

                  V - VoIP-Phone, D - Remotely-Managed-Device,

                  s - Supports-STP-Dispute

 

Device-ID          Local Intrfce  Hldtme Capability  Platform      Port ID

N9K-1(9WFMJJAQIPW)

                    Eth1/1         132    R S s     N9K-NXOSV     Eth1/1

N9K-2(9J3PD595VY7)

                    Eth1/2         136    R S s     N9K-NXOSV     Eth1/1

R5                  Eth1/7         132    R         7206VXR       Fas0/0

 

Total entries displayed: 3

N9K-3# show ip os neighbors

 OSPF Process ID 1 VRF default

 Total number of neighbors: 2

 Neighbor ID     Pri State            Up Time  Address         Interface

 10.1.1.1          1 FULL/ -          3d22h    192.168.13.1    Eth1/1

 10.1.1.2          1 FULL/ -          3d22h    192.168.23.2    Eth1/2

N9K-3# show ip route

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

 

10.0.0.1/32, ubest/mbest: 2/0

    *via 192.168.13.1, Eth1/1, [110/41], 3d22h, ospf-1, intra

    *via 192.168.23.2, Eth1/2, [110/41], 3d22h, ospf-1, intra

10.1.1.1/32, ubest/mbest: 1/0

    *via 192.168.13.1, Eth1/1, [110/41], 3d22h, ospf-1, intra

10.1.1.2/32, ubest/mbest: 1/0

    *via 192.168.23.2, Eth1/2, [110/41], 3d22h, ospf-1, intra

10.1.1.3/32, ubest/mbest: 2/0, attached

    *via 10.1.1.3, Lo0, [0/0], 3d17h, local

    *via 10.1.1.3, Lo0, [0/0], 3d17h, direct

10.1.1.4/32, ubest/mbest: 2/0

    *via 192.168.13.1, Eth1/1, [110/81], 3d22h, ospf-1, intra

    *via 192.168.23.2, Eth1/2, [110/81], 3d22h, ospf-1, intra

192.168.13.0/24, ubest/mbest: 1/0, attached

    *via 192.168.13.3, Eth1/1, [0/0], 3d22h, direct

192.168.13.3/32, ubest/mbest: 1/0, attached

    *via 192.168.13.3, Eth1/1, [0/0], 3d22h, local

192.168.14.0/24, ubest/mbest: 1/0

    *via 192.168.13.1, Eth1/1, [110/80], 3d22h, ospf-1, intra

192.168.23.0/24, ubest/mbest: 1/0, attached

    *via 192.168.23.3, Eth1/2, [0/0], 3d22h, direct

192.168.23.3/32, ubest/mbest: 1/0, attached

    *via 192.168.23.3, Eth1/2, [0/0], 3d22h, local

192.168.24.0/24, ubest/mbest: 1/0

    *via 192.168.23.2, Eth1/2, [110/80], 3d22h, ospf-1, intra

N9K-3#

N9K-3# show ip pim neighbor

PIM Neighbor Status for VRF "default"

Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD

                                                         Priority Capable State

192.168.13.1    Ethernet1/1          3d22h     00:01:41  1        yes     n/a

192.168.23.2    Ethernet1/2          3d22h     00:01:19  1        yes     n/a

N9K-3# show ip mroute

IP Multicast Routing Table for VRF "default"

 

(*, 232.0.0.0/8), uptime: 3d22h, pim ip

  Incoming interface: Null, RPF nbr: 0.0.0.0, uptime: 3d22h

  Outgoing interface list: (count: 0)

 

(*, 234.1.1.1/32), uptime: 1d06h, nve ip pim

  Incoming interface: Ethernet1/1, RPF nbr: 192.168.13.1, uptime: 1d06h

  Outgoing interface list: (count: 1)

    nve1, uptime: 1d06h, nve

 

(10.1.1.3/32, 234.1.1.1/32), uptime: 1d06h, nve ip mrib pim

  Incoming interface: loopback0, RPF nbr: 10.1.1.3, uptime: 1d06h

  Outgoing interface list: (count: 1)

    Ethernet1/2, uptime: 1d06h, pim

 

(10.1.1.4/32, 234.1.1.1/32), uptime: 1d05h, ip mrib nve pim

  Incoming interface: Ethernet1/2, RPF nbr: 192.168.23.2, uptime: 1d05h

  Outgoing interface list: (count: 1)

    nve1, uptime: 1d05h, nve

 

N9K-3# show ip pim rp

PIM RP Status Information for VRF "default"

BSR disabled

Auto-RP disabled

BSR RP Candidate policy: None

BSR RP policy: None

Auto-RP Announce policy: None

Auto-RP Discovery policy: None

 

Anycast-RP 10.0.0.1 members:

  10.1.1.1  10.1.1.2

 

RP: 10.0.0.1, (0), uptime: 3d22h, expires: never,

  priority: 0, RP-source: (local), group ranges:

      224.0.0.0/4

 

N9K-3# show nve vni

Codes: CP - Control Plane        DP - Data Plane

       UC - Unconfigured         SA - Suppress ARP

 

Interface VNI      Multicast-group   State Mode Type [BD/VRF]      Flags

--------- -------- ----------------- ----- ---- ------------------ -----

nve1      10000    234.1.1.1         Up    DP   L2 [100]

 

N9K-3#

N9K-3# show nve peers

Interface Peer-IP          State LearnType Uptime   Router-Mac

--------- ---------------  ----- --------- -------- -----------------

nve1      10.1.1.4         Up    DP        1d05h    n/a

 

N9K-3#

N9K-3#

 

NXOS-4:

N9K-4# show cdp neighbors

Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater,

                  V - VoIP-Phone, D - Remotely-Managed-Device,

                  s - Supports-STP-Dispute

 

Device-ID          Local Intrfce  Hldtme Capability  Platform      Port ID

N9K-1(9WFMJJAQIPW)

                    Eth1/1         156    R S s     N9K-NXOSV     Eth1/2

N9K-2(9J3PD595VY7)

                    Eth1/2         179    R S s     N9K-NXOSV     Eth1/2

R6                  Eth1/7         131    R         7206VXR       Fas0/0

 

Total entries displayed: 3

N9K-4# show ip ospf neighbors

 OSPF Process ID 1 VRF default

 Total number of neighbors: 2

 Neighbor ID     Pri State            Up Time  Address         Interface

 10.1.1.1          1 FULL/ -          3d22h    192.168.14.1    Eth1/1

 10.1.1.2          1 FULL/ -          3d22h    192.168.24.2    Eth1/2

N9K-4# show ip route

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

 

10.0.0.1/32, ubest/mbest: 2/0

    *via 192.168.14.1, Eth1/1, [110/41], 3d22h, ospf-1, intra

    *via 192.168.24.2, Eth1/2, [110/41], 3d22h, ospf-1, intra

10.1.1.1/32, ubest/mbest: 1/0

    *via 192.168.14.1, Eth1/1, [110/41], 3d22h, ospf-1, intra

10.1.1.2/32, ubest/mbest: 1/0

    *via 192.168.24.2, Eth1/2, [110/41], 3d22h, ospf-1, intra

10.1.1.3/32, ubest/mbest: 2/0

    *via 192.168.14.1, Eth1/1, [110/81], 3d17h, ospf-1, intra

    *via 192.168.24.2, Eth1/2, [110/81], 3d17h, ospf-1, intra

10.1.1.4/32, ubest/mbest: 2/0, attached

    *via 10.1.1.4, Lo0, [0/0], 3d22h, local

    *via 10.1.1.4, Lo0, [0/0], 3d22h, direct

192.168.13.0/24, ubest/mbest: 1/0

    *via 192.168.14.1, Eth1/1, [110/80], 3d22h, ospf-1, intra

192.168.14.0/24, ubest/mbest: 1/0, attached

    *via 192.168.14.4, Eth1/1, [0/0], 3d22h, direct

192.168.14.4/32, ubest/mbest: 1/0, attached

    *via 192.168.14.4, Eth1/1, [0/0], 3d22h, local

192.168.23.0/24, ubest/mbest: 1/0

    *via 192.168.24.2, Eth1/2, [110/80], 3d22h, ospf-1, intra

192.168.24.0/24, ubest/mbest: 1/0, attached

    *via 192.168.24.4, Eth1/2, [0/0], 3d22h, direct

192.168.24.4/32, ubest/mbest: 1/0, attached

    *via 192.168.24.4, Eth1/2, [0/0], 3d22h, local

N9K-4#

N9K-4# show ip pim neighbor

PIM Neighbor Status for VRF "default"

Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD

                                                         Priority Capable State

192.168.14.1    Ethernet1/1          3d22h     00:01:37  1        yes     n/a

192.168.24.2    Ethernet1/2          3d22h     00:01:21  1        yes     n/a

N9K-4# show ip mroute

IP Multicast Routing Table for VRF "default"

 

(*, 232.0.0.0/8), uptime: 23:30:29, pim ip

  Incoming interface: Null, RPF nbr: 0.0.0.0, uptime: 23:30:29

  Outgoing interface list: (count: 0)

 

(*, 234.1.1.1/32), uptime: 23:30:29, nve ip pim

  Incoming interface: Ethernet1/2, RPF nbr: 192.168.24.2, uptime: 23:30:29

  Outgoing interface list: (count: 1)

    nve1, uptime: 23:30:29, nve

 

(10.1.1.3/32, 234.1.1.1/32), uptime: 23:30:29, ip nve pim mrib

  Incoming interface: Ethernet1/2, RPF nbr: 192.168.24.2, uptime: 23:30:29

  Outgoing interface list: (count: 1)

    nve1, uptime: 23:30:29, nve

 

(10.1.1.4/32, 234.1.1.1/32), uptime: 23:30:29, ip nve pim

  Incoming interface: loopback0, RPF nbr: 10.1.1.4, uptime: 23:30:29

  Outgoing interface list: (count: 2)

    Ethernet1/1, uptime: 00:00:09, pim

    Ethernet1/2, uptime: 23:30:29, pim

 

N9K-4#

N9K-4# show ip pim rp

PIM RP Status Information for VRF "default"

BSR disabled

Auto-RP disabled

BSR RP Candidate policy: None

BSR RP policy: None

Auto-RP Announce policy: None

Auto-RP Discovery policy: None

 

Anycast-RP 10.0.0.1 members:

  10.1.1.1  10.1.1.2

 

RP: 10.0.0.1, (0), uptime: 3d22h, expires: never,

  priority: 0, RP-source: (local), group ranges:

      224.0.0.0/4

N9K-4#

N9K-4# show nve vni

Codes: CP - Control Plane        DP - Data Plane

       UC - Unconfigured         SA - Suppress ARP

 

Interface VNI      Multicast-group   State Mode Type [BD/VRF]      Flags

--------- -------- ----------------- ----- ---- ------------------ -----

nve1      10000    234.1.1.1         Up    DP   L2 [100]

 

N9K-4# show nve peers

Interface Peer-IP          State LearnType Uptime   Router-Mac

--------- ---------------  ----- --------- -------- -----------------

nve1      10.1.1.3         Up    DP        1d06h    n/a

 

N9K-4#


本次实验本人原创,转载请说明

标签: Cisco VXLAN NXOS Nexus9K

评论:

fixpro
2018-08-01 16:32
请问一下,我下载了,用EVE导入,但是开了三台就开不了。服务器资源是够的。48核、256G内存。尝试用ESXI可以开8台都没事。你是用什么开的?
hale
2018-08-30 14:13
@fixpro:我也是EVE打开的,开完一台完成后在开另外一台。
llhy615
2017-07-06 23:27
你好,请问能否共享下NXOS9K的镜像,谢谢!
hale
2017-07-07 09:35
@llhy615:文件实在是太大,分享很不方便。谷歌搜索nxosv-final.7.0.3.I6.1.ova
说不定有下载。
llhy615
2017-07-07 12:06
@hale:请教下,我已经下载下来了,我看license都没有,license如何搞定?谢谢
hale
2017-07-09 22:29
@llhy615:不需要许可,可以直接使用。有流量限制,不过不影响实验。

发表评论:

Powered by emlog 苏ICP备11083054号-1